Mumble and Ventrilo issues

Discussion in 'Technology' started by JohnnyGaloshes, Nov 14, 2016.

  1. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor

    OK so for a long time i have been having the same damn problem on both Mumble and Ventrilo. I randomly lose connection and rejoin. Sometimes a lot, sometimes not all day.

    I thought it was packet loss. Checked that and no packet loss from the tests i have done. Moved the server closer to me. Didn't help. Switched from mumble to Ventrilo. Didn't help. Have a brand new computer system. Didn't help. Switched my ethernet cord to a new one (I'll try anything at this point). Didn't help. Turned off "QOS" on Mumble. didn't help.

    I know it says "ghost disconnect" on mumble when it disconnects me. And on Vent when i lose connection and rejoin, there is the old me still in the room.

    I have looked high and low on forums and the internet and have yet to find a fix.

    Someone have any advice???
     
  2. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    Do you have any QoS setup on your router? You might check your router settings.
     
  3. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    Voice transmission data is probably going to be UDP packets so you might look around for UDP settings.
     
  4. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor


    My router is a POS to say the least. Provided by my ISP and u have to use theirs. I will check into it and advise.
     
  5. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor

    I can't change my QoS on my router.

    I have mumble port forwarded already.
     
  6. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    You have the mumble port forwarded on your router? Or you whitelisted the port through windows firewall? Or both?

    You might of had to allow the port in the firewall but you shouldn't need to port forward to your router. I would advise against that. I forwarded a VPN port to my router so that I could VPN into my home network from work, within 1 day I started seeing Chinese IP addresses trying to get in through that port. Bad people of constantly scanning IPs for open ports.

    Is this machine connecting through wireless or with Ethernet?
     
  7. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor

    Opened a port on my router, and whitelisted it on my firewall.

    It is plugged in. It even does it on wireless.
     
  8. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    Are we talking clients? Are you trying to run servers?
     
  9. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor

    Client
     
  10. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    Is it a mumble that you/someone has rented from a company like NFO or is someone running the sever privately ?
     
    • Like Like x 1
  11. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    A couple things you can try if you want:
    1 remove the port forwarding to your router.
    2 there should be an option to force TCP in mumble options. You can try turning that on. TCP requires acknowledgment packets that could give you an idea is where the error is, instead of the UDP packets just getting dropped.
     
    • Like Like x 2
  12. JohnnyGaloshes

    JohnnyGaloshes Gaben's Own Aimbot Contributor

    Ok I'll do that in a few days when back home. Thanks.
     
  13. chuckwagon

    chuckwagon TF2 Admin Contributor

    Steam:

    And the reason I ask about public/private servers is I found some info that if someone is running a private server and have power settings set so the the computer goes to sleep it will loose connection causing ghost disconnects. If it is a dedicated rented mumble server you can rule that out.

    Yeah just let me know once you get home. I'll do what I can to help.